Square Service Disruption
Incident Report for Chowly
Resolved
After careful monitoring, we can confirm that the main service disruption is resolved. We appreciate your patience with us today.
Posted Feb 06, 2024 - 17:31 CST
Monitoring
Square is continuing to monitor the recovery of the systems. Accepted payments will be processed normally, but there may be a delay in updates to your balance. We kindly ask you to remain logged into your account as we work toward a full resolution. Thank you for your patience.
Posted Feb 06, 2024 - 13:18 CST
Identified
Square POS has identified the issue and implemented a fix, and the system is beginning to recover. Please continue to stay logged into your account and follow any instructions in your point-of-sale banner.
Posted Feb 06, 2024 - 12:28 CST
Update
We are continuing to investigate this issue.
Posted Feb 06, 2024 - 10:40 CST
Update
Square is continuing to investigate this issue in order to ensure a return to normal operations. During this time, sellers may experience some delays across certain products. Please use an alternative Two-Step Verification method to authenticate instead of SMS. If you are already logged in to your account, please do not log out. For more information, visit the following link: https://www.issquareup.com/
Posted Feb 06, 2024 - 10:37 CST
Investigating
Square is currently experiencing a disruption that is impacting some Square point of sale services. We understand how important it is for your business for all of the services to be up and running, and the Engineering team is actively working on a fix. Thank you for your patience with us as we work to resolve this issue.
Posted Feb 06, 2024 - 10:35 CST
This incident affected: Point Of Sale (Square).