Phone Lines Down
Incident Report for Chowly
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 16:13 CST
Update
Our Support line are up and running
Posted Feb 06, 2024 - 16:12 CST
Monitoring
Our Partners technical team has implemented the necessary measures to restore services.

The team is continuously monitoring the platform closely and will remain proactive in addressing any service issues that may arise.
Posted Feb 06, 2024 - 15:20 CST
Investigating
We are aware of call connectivity Issues impacting our support line. Our partners are aware and are working to restore full call connectivity as soon as possible. Our support team is available and ready to assist you through chat and SMS. You can text us at 1-866-674-0469 or visit our website at www.chowly.help to initiate a chat immediately or open a support case.

We will update our status page with further details as soon as we have an update from them.
Posted Feb 06, 2024 - 14:32 CST
This incident affected: Customer Care (Phone Line).