Clover Connectivity Issue

Incident Report for Chowly

Resolved

The issue has been resolved, and all Clover systems are working as expected.
Posted Mar 28, 2025 - 14:21 CDT

Investigating

Clover is experiencing some intermittent issues at this time. Clover is currently investigating this issue.
Posted Mar 28, 2025 - 14:05 CDT
This incident affected: Point Of Sale (Clover).