Revel Order not integrating
Incident Report for Chowly
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 12:40 CDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2024 - 12:40 CDT
Update
We are continuing to investigate this issue.
Posted Mar 24, 2024 - 19:10 CDT
Investigating
Revel orders are not integrating. We are currently investigating the issue.
Posted Mar 24, 2024 - 18:17 CDT
This incident affected: Point Of Sale (Revel).